Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mixbus v2.5 : Use Stereo VST's in mono tracks
04-29-2014, 11:24 AM
Post: #1
Mixbus v2.5 : Use Stereo VST's in mono tracks
Forum users will be excited to see that we have addressed a long-standing limitation with VST plugins on the Windows version of Mixbus.

The Mixbus DSP engine requires that all channels operate in either mono (1-channel) or stereo (2-channel) mode. In the past, this limited the use of VST plugins, because VSTs cannot change their I/O counts to adapt to the kind of channel they are loaded into. This meant that the most common VST format (stereo) couldn't be used on a mono channel. And plugins with more than 2 inputs couldn't be used in mono or stereo channels, so they were completely unavailable in Mixbus. This has been solved in version 2.5!

Here's what to do:


To load more VST plugins, you will need to re-scan the plugins on your system. To do that, please click Window->Preferences->Plugins. Click "Clear Paths & Cache". Note: Please first make a note of the VST paths, because you will have to recreate it after you clear the plugin cache. Then click "Scan for Plugins". This will recreate your plugin list, and you will see 2 differences. First, every plugin will have a partner plugin, denoted by plugin_name>1, which indicates that it is a new "mono" version of the plugin. Secondly, the plugins that previously had too many I/O (such as 3/2 or 8/8) will now appear as stereo-only, which will allow them to be used in stereo channels and mixbuses!

You'll have to choose a separate plugin for the mono versions, which might make your Favorites list harder to manage. But we think you will agree that it is a workable solution to use more of your VST plugins.

Thanks for your continued support!
Find all posts by this user
Quote this message in a reply
04-29-2014, 02:15 PM (This post was last modified: 04-29-2014 02:16 PM by Tassy.)
Post: #2
RE: Mixbus v2.5 : Use Stereo VST's in mono tracks
Maybe it is not necessary after the above "Clear Paths & Cache", but just for sure for those who had made a manual edit, before the 2.5 release, in the ,fft files of the plugs to convert them into mono I may advise to delete these converted plugs .fft files they had edited. When rescanning the plugins the original .fft will be put there by Mixbus.

I recommend it only if you have in the plugin manager both your converted "mono" plug and the new mono ">1" plug created by 2.5.

As to the VSTs that had original mono versions of their plugin, I hid the new ">1" ones in plugin manager not to take place in the insert rolldown list.

Harrison Guys made us "King of mixers" by their great solution in 2.5.
Thanks a lot
Tassy
Find all posts by this user
Quote this message in a reply
05-03-2014, 04:31 PM
Post: #3
RE: Mixbus v2.5 : Use Stereo VST's in mono tracks
Hey guys, I did edit a couple of plugs .fft files to convert to mono. As best as I can tell, only the new ">1" ones are in the plugin manager. I ran a rescan of plugs after I installed 2.5, but I did not clear cache, because I had a hell of a time getting my waves plugs scanned and working when I first got Mixbus. I'm very afraid that I might have a problem with them again. Is it necessary to clear cache when updating Mixbus to 2.5? All the plugs I have tried so far seem to be working properly. Is it necessary to delete the edited .fft files? thanks a lot, I just want this to be correct since the guys at Harrison gave us what we want!
Find all posts by this user
Quote this message in a reply
05-04-2014, 12:36 AM
Post: #4
RE: Mixbus v2.5 : Use Stereo VST's in mono tracks
Hi Milton
On my win7 system I just deleted the edited mono .fft files in order not to have two mono of the same plugs. I did it before the advice to clear cash. I have not cleared it so far since all the new ">1" ones work fine after rescanning.
My motto is "if something works don't touch itSmile"
Find all posts by this user
Quote this message in a reply
05-04-2014, 07:24 AM
Post: #5
RE: Mixbus v2.5 : Use Stereo VST's in mono tracks
(05-04-2014 12:36 AM)Tassy Wrote:  Hi Milton
On my win7 system I just deleted the edited mono .fft files in order not to have two mono of the same plugs. I did it before the advice to clear cash. I have not cleared it so far since all the new ">1" ones work fine after rescanning.
My motto is "if something works don't touch itSmile"
AMEN on don't touch! I think I'm going to leave everything alone unless I run into a problem. Thanks!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)